Username: Password:

Author Topic: 4.0.X - How to run Proxy CE  (Read 4009 times)

Offline criptonauta

  • Contributor
  • **
  • Posts: 137
    • View Profile
4.0.X - How to run Proxy CE
« on: August 15, 2017, 10:58:09 PM »
Hello Guns!


While my 4.0.1 / 4.0.2 were trading even showing sparse cycles in the monitor, I wondered, like other users, if Proxy CE could be used with it until a GB release solves the sparse cycles thing in a definitive way.

By reading the official release notes, I already knew it could be used with PM2. In Proxy CE chat, Diesel had already share the useful yaml file he's using, but I would not like to pm2.

On the other side, how to add the NODE_TLS_REJECT_UNAUTHORIZED=0 ?

Being novice in Linux, I went again to Proxy CE chat for some help and Jeff B pointed that it could be easily achieved with a bash script.

I tested and it's working gracefully. Here are the steps:

  • Configure you proxy as in the official page
  • Download the attached file  in this post and and save in your Gunbot folder
  • Alternatively, you can open a text editor add the lines below and save it as proxy.sh:
Code: [Select]
#!/bin/bash
NODE_TLS_REJECT_UNAUTHORIZED=0 ./gunthy-linx64
  • In your GB folder, make it executable: chmod +x proxy.sh
  • Run your proxy
  • Run Gunbot by typing: ./proxy.sh
  • Trade  :)


Thanks for Diesel and Jeff B for helping me with the issue and Elroy for keeping the proxy updated. Please donate to him (also for other devs like Beer K0in, Andrew and others)... donation rate is low and utilization of their tools  is high.
   ✔ FAST, APPROVED AND EASY Escrow for used GunBot licenses @ 5% ..:..Gunbot licenses 10% off: 'Criptonauta_Gun' code. | Tuning, Custom Strats | No VPS? Get yours here   ✔

Offline Cryptognorbe

  • Rookie
  • *
  • Posts: 3
    • View Profile
Re: 4.0.X - How to run Proxy CE
« Reply #1 on: August 24, 2017, 09:33:09 AM »
And for Windows users?