Username: Password:

Author Topic: Telegram No Bot token  (Read 287 times)

Offline dinger

  • Rookie
  • *
  • Posts: 2
    • View Profile
Telegram No Bot token
« on: August 24, 2020, 05:52:24 PM »
I have had my telegram bot setup and working great, but last week it started giving me this error when starting gunbot:

Loading config...
(Telegram) Starting bot as Gunbot
(Telegram) Error: Missing bot token
   info  - socket.io started

I checked to make sure the bot token was still there and it is unchanged.  I then verified that the bot token was correct and ever went as far as revoking that token and getting a new one.  After I updated the configuration with the new token, I continue to get the missing bot token error.  Any insight to this would be appreciated.

Offline Aitor

  • Administrator
  • *****
  • Posts: 410
  • Telegram: @AitorRuiz Gunbot.shop
    • View Profile
    • Gunbot
Re: Telegram No Bot token
« Reply #1 on: August 24, 2020, 09:03:00 PM »
The error can be caused just because you didn't copy / paste the token code properly in "Token" field. Even if this is ok, in the case you activated "Autoconfig Telegram bot Enabled" in v18 or  "Autoconfig Alerts"  in v19, you need to put the second token in the field: ""Token for BitRage & Autoconfig alerts", and in the case you don't, you get the error.

Offline dinger

  • Rookie
  • *
  • Posts: 2
    • View Profile
Re: Telegram No Bot token
« Reply #2 on: August 24, 2020, 11:43:37 PM »
I double checked and made sure the token id is correct.  I also put the id in the other two fields, even though I am not using them.  I still get the error no token.

Offline Aitor

  • Administrator
  • *****
  • Posts: 410
  • Telegram: @AitorRuiz Gunbot.shop
    • View Profile
    • Gunbot
Re: Telegram No Bot token
« Reply #3 on: August 27, 2020, 12:41:11 AM »
I double checked and made sure the token id is correct.  I also put the id in the other two fields, even though I am not using them.  I still get the error no token.

If you are using only the main Telegram bot, then just fill the Token field and don't enable "Autoconfig alerts" and don't fill other tokens.
If you are running just the main Telegram bot and you are getting "Missing bot token" there can only be one reason: the token field is empty or the token is not valid. So just fill the main token and be sure you fill it like this: