Username: Password:

Author Topic: my gunbot shows strange behavior, not sure if this is normal  (Read 392 times)

Offline Alphadan

  • Rookie
  • *
  • Posts: 31
    • View Profile
my gunbot shows strange behavior, not sure if this is normal
« on: March 19, 2020, 01:31:16 PM »
The chart is empty, not sure if i should see a chart with the pair or something, also sometimes it does like a update of the page and the layout changes

from this:



to this:



also when im trying to edit settings this logo sudently appears:



interrupting what im doing and erasing all changes I'm making, so i need to change settings and save quick b4 that happens or need to start all over again.

do u recommend fallback to a more stable version? or there is a fix for the problem.


My setup

Gunbot ver:  18.3.9

Virtualization: VirtualBox
Operating System: Linux Mint 19.3
Kernel: Linux 5.0.0-32-generic

Offline CryptoDROI

  • Rookie
  • *
  • Posts: 34
  • Daily Return On bitRage
    • View Profile
    • Crypto Daily Return On Investment
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #1 on: March 19, 2020, 06:33:59 PM »
Can you provide more info, like your console logs?

I think telegram is better for this, you can contact me there if you're not in the Elite room
#VIRALTrading -Check Official Gunthy News: https://viraltrading.org/

Offline Alphadan

  • Rookie
  • *
  • Posts: 31
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #2 on: March 19, 2020, 08:42:55 PM »
thx for the offer, but just wiped that image, currently installing gunbot ARM in a raspberry which was my original idea installed in mint first to test, if still having issues will contact you for help  :)

Offline CryptoDROI

  • Rookie
  • *
  • Posts: 34
  • Daily Return On bitRage
    • View Profile
    • Crypto Daily Return On Investment
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #3 on: March 19, 2020, 09:31:05 PM »
No problem, anytime. Hopefully, New GUI gets out soon.
#VIRALTrading -Check Official Gunthy News: https://viraltrading.org/

Offline Alphadan

  • Rookie
  • *
  • Posts: 31
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #4 on: March 19, 2020, 11:13:26 PM »
just for the feedback:

after installing in the ARM (Raspberry pi 2) the issues gone away, the page suddenly updating got fixed, the only issue now are a few hangs but may be because the of the pi not having enough resources. but it feels just fine. atm

Offline sbogovac

  • Rookie
  • *
  • Posts: 65
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #5 on: March 20, 2020, 09:29:30 AM »
just for the feedback:

after installing in the ARM (Raspberry pi 2) the issues gone away, the page suddenly updating got fixed, the only issue now are a few hangs but may be because the of the pi not having enough resources. but it feels just fine. atm

Sounds about right... I switched to a VPS because of that (constant hanging off the RasPi)... and ARM versions of GunBot are always last to come.

Offline Alphadan

  • Rookie
  • *
  • Posts: 31
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #6 on: March 21, 2020, 05:16:58 PM »
i think i tracked the bottle neck, ran this command "free -h -s 1" which post the available memory in the system and it appears that the hangs are memory related since the free memory sometimes goes to 0,  pi2 is only 1GB ram which is 1 GB less than the RAM required in the gunbot wiki.

Offline Alphadan

  • Rookie
  • *
  • Posts: 31
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #7 on: March 22, 2020, 12:26:14 AM »
just installed a raspbian lite image in my pi, left it headless also ran gunbot headless, using the screen tool allowing me to control gunbot from ssh, and so far no more hangs no it runs smooth 100% of the time.

leaving this comments in case someone else wants to run gunbot in a raspberry.

Offline danidpuclin

  • Rookie
  • *
  • Posts: 1
    • View Profile
Re: my gunbot shows strange behavior, not sure if this is normal
« Reply #8 on: May 27, 2020, 04:58:00 PM »
just for the feedback:

after installing in the ARM (Raspberry pi 2) the issues gone away, the page where are a lot of free research proposal samples for students and after it suddenly updating got fixed, the only issue now are a few hangs but may be because the of the pi not having enough resources. but it feels just fine. atm

Sounds about right... I switched to a VPS because of that (constant hanging off the RasPi)... and ARM versions of GunBot are always last to come.

Which version of Raspberry pi 2 have you got?