Username: Password:

Author Topic: 7.0.2 Binance fetchBalance errors  (Read 3679 times)

Offline Moonrunner

  • Rookie
  • *
  • Posts: 6
    • View Profile
7.0.2 Binance fetchBalance errors
« on: December 31, 2017, 05:24:02 PM »
Have been tweaking my GB settings over the past few days , had things running nicely before going to bed , only to wake up seeing a string of license server errors , lost about 7 hours of trading time. Restarted the bot which fixed the license errors but now I get the following errors on some of my pairs on Binance:

error: fetchBalance
Error: Response code 400
    at Request.module.exports._makeRequest.request [as _callback] (/snapshot/gunbot/ctx/helper/binance/binance-api.js:0:0)
    at Request.init.self.callback (/snapshot/gunbot/node_modules/request/request.js:188:22)
    at emitTwo (events.js:125:13)
    at Request.emit (events.js:213:7)
    at Request. (/snapshot/gunbot/node_modules/request/request.js:1171:10)
    at emitOne (events.js:115:13)
    at Request.emit (events.js:210:7)
    at IncomingMessage. (/snapshot/gunbot/node_modules/request/request.js:1091:12)
    at Object.onceWrapper (events.js:312:19)
    at emitNone (events.js:110:20)
    at IncomingMessage.emit (events.js:207:7)
    at endReadableNT (_stream_readable.js:1045:12)
    at _combinedTickCallback (internal/process/next_tick.js:102:11)
    at process._tickCallback (internal/process/next_tick.js:161:9)


Anyone have any idea on how to fix?
Thanks in advance.

Offline TwoScoops

  • Rookie
  • *
  • Posts: 7
    • View Profile
Re: 7.0.2 Binance fetchBalance errors
« Reply #1 on: January 01, 2018, 03:51:46 AM »
Windows fix - https://github.com/GuntharDeNiro/BTCT/issues/351

Still trying to find an OSX fix myself.