Username: Password:

Author Topic: Gunbot Starter taking many attempts to launch?  (Read 236 times)

Offline StarterUser

  • Rookie
  • *
  • Posts: 12
    • View Profile
Gunbot Starter taking many attempts to launch?
« on: August 25, 2022, 04:53:50 AM »
I bought Gunbot Starter in Nov 2020 and used it for a while, then stopped. For most of 2021 and up to now in 2022 I didn't use the bot, it just sat dormant. Now I am planning on trading with it again, everything is setup including my API key and so on.

I'm just having one problem, if I run Gunbot, the command window vanishes in a flash.
If I run it over and over again, I can get it to launch and then it stays running.

I thought maybe my firewall or some other thing is clashing with it, or using port 5000... so I copied the Gunbot folder to a VM where there is nothing installed except Windows 10 x64 - it exhibited the same behavior in the VM - instantly vanishing when launched. I also tried it in a clean VM of Windows 7 x64 and it's the same deal there too.

I'm also making sure it's not already in Task Manager when trying to launch it.

If I reboot Windows (my real system) Gunbot seems to start up first time every time.

I eventually made a looping batch file that tries to launch Gunbot every 10 seconds and I just leave that looping until it starts, or I reboot to get it to launch, but it can be looping for a while before it finally decides to start.

If it just never launched I could understand it but it does after many many attempts.

I am sure last time trading in late 2020 and early 2021, I was using Windows 7.
I have tried setting the Gunbot exe to Windows 7 compatibility mode but it did nothing to help.

This Starter version is from March 2021 and it looks like there will never be an update to it?

Is there any patch, or anything I could apply to it?

It's not even the config file, it still vanishes as soon as it's launched, with the config.js that's included with the download.

I don't know if flushing the DNS cache might help, but I did also try that.

It's just crashing as soon as I click it, probably 29 out of 30 times trying to launch it. If I leave it alone for a minute, sometimes it launches right away, after trying over and over, a minute ago.

Everything is setup from last time because like I said, it's not my first time using the bot. My pairs, strategy, API and the right password for Gunbot is all how it should be and I have had the bot cycling perfectly fine and connecting to Binance.

Just so you know which bot version this is, the MD5 is:
e3f25c2de60f1951dc3978cca2600044

From the usual Github page.

Cheers folks.

Offline Aitor

  • Administrator
  • *****
  • Posts: 561
  • Telegram: @AitorRuiz Gunbot.shop
    • View Profile
    • Gunbot
Re: Gunbot Starter taking many attempts to launch?
« Reply #1 on: October 08, 2022, 05:10:00 PM »
Starter is outdated, now that version doesn't exit. There is a super cheap update to Standard:

https://gunbot.shop/product/upgrade-to-gunbot-standard/