Username: Password:

Author Topic: GB xt on lynux vps not reading .conf  (Read 3683 times)

Offline jim

  • Rookie
  • *
  • Posts: 36
    • View Profile
GB xt on lynux vps not reading .conf
« on: November 11, 2017, 01:25:41 AM »
I think gb is trying to run but it cant read the .conf file I had to put another } at the end to make the file validate and  I have tried changing the port from 5001 to 5000 but that does not help

 


0|gunthy-l | Detected config changes...
0|gunthy-l | Loading config...
0|gunthy-l | Unhandled rejection TypeError: Cannot read property 'port' of undefined
0|gunthy-l |     at new Websocket (/snapshot/gunbot-build/websocket.js:0:0)
0|gunthy-l |     at loadWS (/snapshot/gunbot-build/bot.lib.js:0:0)
0|gunthy-l |     at Bot.start.loadConfig.then (/snapshot/gunbot-build/bot.lib.js:0:0)
0|gunthy-l |     at tryCatcher (/snapshot/gunbot-build/node_modules/bluebird/js/release/util.js:16:23)
0|gunthy-l |     at Promise.module.exports.Promise._settlePromiseFromHandler (/snapshot/gunbot-build/node_modules/bluebird/js/release/promise.js:512:31)
0|gunthy-l |     at Promise.module.exports.Promise._settlePromise (/snapshot/gunbot-build/node_modules/bluebird/js/release/promise.js:569:18)
0|gunthy-l |     at Promise.module.exports.Promise._settlePromise0 (/snapshot/gunbot-build/node_modules/bluebird/js/release/promise.js:614:10)
0|gunthy-l |     at Promise.module.exports.Promise._settlePromises (/snapshot/gunbot-build/node_modules/bluebird/js/release/promise.js:693:18)
0|gunthy-l |     at Async._drainQueue (/snapshot/gunbot-build/node_modules/bluebird/js/release/async.js:133:16)
0|gunthy-l |     at Async._drainQueues (/snapshot/gunbot-build/node_modules/bluebird/js/release/async.js:143:10)
0|gunthy-l |     at Immediate.__dirname.Async.drainQueues (/snapshot/gunbot-build/node_modules/bluebird/js/release/async.js:17:14)
0|gunthy-l |     at runCallback (timers.js:800:20)
0|gunthy-l |     at tryOnImmediate (timers.js:762:5)
0|gunthy-l |     at processImmediate [as _immediateCallback] (timers.js:733:5)

this is the end of the .conf file

    "ws": {
        "port": 5001,
        "clientport": 3000,
        "hostname": "127.0.0.1"
    },
    "imap_listener": {
        "enabled": false,
        "authorized_froms": "[\"noreply@tradingview.com\"]",
        "user": "YOUR_EMAIL_HERE",
        "password": "YOUR_PASSWORD_HERE",
        "host": "imap.gmail.com",
        "port": 993,
        "tls": true,
        "tlsOptions": {
            "rejectUnauthorized": false
        }
    }
}
}