Username: Password:

Author Topic: Systems have detected you are in a location we cannot provide service to.  (Read 4463 times)

Offline bney

  • Rookie
  • *
  • Posts: 29
    • View Profile
I am seeing this error in the logs and the bot is failing on all coins.
My Gunbot is running in a VPS in Digital Ocean, San Fran.
Anyone know what this error means and how to get rid of it?


Offline bney

  • Rookie
  • *
  • Posts: 29
    • View Profile
Found the problem.

Im posting it here so that if anyone else runs into it they can easily fix it.

Don't start a VPS in Digital Ocean New York. Since the New York Crypto Coin Nazies have forbidden all trading and activities there unless you pay some godawful bribe to the state, Poloniex sees the connect from a NY IP address and blocks your account.

Go log into the POLO account and correct your state and all will instantly be fine again.


Offline allanster

  • Contributor
  • **
  • Posts: 128
  • lux ex tenebris
    • View Profile
Confused, were you actually running from San Fran or just made simple mistake and was running from New York?

All of this is ridiculous, I laugh at watching all of these bureaucrats panic as their power (and more importantly money) is steadily bleeding out to the people.

After all, where is your bitcoin? They just don't get it, it's everywhere, it's in your machine, it's in your head.
more human than human

Offline bney

  • Rookie
  • *
  • Posts: 29
    • View Profile
I happened to have a server running in New York. I knew NY had that stupid rule, just didnt think about the restriction. I took a snapshot and moved it to SF and all is well. Tho I did have to reverify with POLO that I wasnt actually in NY.

Offline allanster

  • Contributor
  • **
  • Posts: 128
  • lux ex tenebris
    • View Profile
Thanks for clearing up. Now makes sense. Do they have Windows?
more human than human

Offline bney

  • Rookie
  • *
  • Posts: 29
    • View Profile
Digital ocean doesn't appear to have windows available. They have various nix flavors.

Offline allanster

  • Contributor
  • **
  • Posts: 128
  • lux ex tenebris
    • View Profile
@bney

Thanks for answer. I'm running on Windows 10 now and it seems really buggy. Looks like all the cool kids are doing nix. Do you know if there's a preferred or more popular flavor being used by the big guns in here?

I'm comfortable with whichever, prefer security over user friendly though.
more human than human

Offline kin0

  • Rookie
  • *
  • Posts: 19
    • View Profile
Waht does the phrase *NO LP FOUND* mean within the bot?

Offline bney

  • Rookie
  • *
  • Posts: 29
    • View Profile
In answer to your question regarding which nix flavor, Im using ubuntu.
I used the following installation script to install the Gunbot and the other things it depends on, specifically node.
https://gunthy.org/index.php?topic=277.0